Ubuntu 11.10 oneric y Ultrastar deluxe

Problemas y dudas sobre el mejor programa para cantar y en general sobre cualquier programa relacionado con el mismo
Reglas del Foro
Prohibido pedir canciones en el foro. Si quieres hacerlo que sea aqui

Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor ruben0909 » Jueves 27 de Octubre de 2011 a las 18:50

Me gustaría instalar Ultrastar deluxe en un servidor ubuntu 11.10

Pero me da errores de dependencias, ahoora mismo no lo puedo comprobar cuales son exactamente.
Luego lo pondré....
Pero me gustaría saber si alguien lo ha conseguido instalar en esta versión de ubuntu.(11.10, no servidor o servidor eso da igual)

Y por otro lado
He leido que el ultrastar-ng no lee avi y que el creador ha avandonado el prooyecto. ¿Es todo esto correcto?


Lo digo porque la ultima build del ng es del 2011-08-08
y si hay para ubuntu oneric, no como en el caso del deluxe.

¿Alguien sabe si sacarán pronto una versión para el deluxe?

Muchas gracias, un saludo
ruben0909
Desafinado
 
Mensajes: 1
Registrado: Miércoles 14 de Abril de 2010 a las 01:57

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor daniel20 » Jueves 27 de Octubre de 2011 a las 20:50

¿has probado a escribir "instalar ubuntu" en el buscador del foro?
¿no sabes cómo configurar tus micros? ¿no sabes descargar? ¿problemas? Quizás tu duda ya ha sido resuelta en la sección de Ayuda (arriba en la web)
Avatar de Usuario
daniel20
Moderador
Moderador
 
Mensajes: 4040
Registrado: Viernes 27 de Febrero de 2009 a las 19:50

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor TeLiX » Viernes 28 de Octubre de 2011 a las 15:55

en cuanto al ultrastar-ng que yo sepa ahora es el performous que no esta abandonado, por tanto si que vas a poder instalarlo
No respondo a mensajes privados sobre temas que podrían estar en el foro
Avatar de Usuario
TeLiX
Administrador
Administrador
 
Mensajes: 6527
Registrado: Sábado 22 de Noviembre de 2008 a las 14:25

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor monkeymonkey » Lunes 7 de Noviembre de 2011 a las 07:07

Este no es un simple problema de no leer la documentación de ubuntu!... en la versión 11.10 han cambiado paquetes clave para el funcionamiento de ultrastar ...yo trate de cambiarle las dependencias al paquete de ultrastar y lo pude instalar pero luego no arrancaba. en la version 11.04 de ubuntu anda sin problemas pero en la 11.10 es otra cosa.
por favor que alguien de con la solucion.
monkeymonkey
Desafinado
 
Mensajes: 1
Registrado: Lunes 7 de Noviembre de 2011 a las 06:58

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor jfcg » Sábado 19 de Noviembre de 2011 a las 14:40

Hay que instalar los paquetes que requiere el Ultrastar, es decir, los siguientes:

http://packages.ubuntu.com/maverick/amd ... 2/download
http://packages.ubuntu.com/maverick/amd ... 8/download
http://packages.ubuntu.com/maverick/amd ... 2/download
http://packages.ubuntu.com/maverick/amd ... 0/download
http://packages.ubuntu.com/maverick/amd ... 0/download

He puesto el enlace directo para la arquitectura de 64 bits, en el caso de 32 bits sería:
http://packages.ubuntu.com/maverick/i38 ... 2/download
... etc, sustituyendo el "amd64" por "i386". Lo único que tenéis que hacer es, como siempre, "sudo dpkg -i nombre_paquete.deb"

Yo ya lo tengo funcionando y es genial. Os aconsejo que os guardéis esos archivos descargados por si no se actualiza el programa en un tiempo.

¡Espero que sirva de ayuda!
jfcg
Desafinado
 
Mensajes: 1
Registrado: Domingo 21 de Agosto de 2011 a las 11:44

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor crow0300 » Domingo 29 de Enero de 2012 a las 22:58

jfcg escribió:Hay que instalar los paquetes que requiere el Ultrastar, es decir, los siguientes:

http://packages.ubuntu.com/maverick/amd ... 2/download
http://packages.ubuntu.com/maverick/amd ... 8/download
http://packages.ubuntu.com/maverick/amd ... 2/download
http://packages.ubuntu.com/maverick/amd ... 0/download
http://packages.ubuntu.com/maverick/amd ... 0/download

He puesto el enlace directo para la arquitectura de 64 bits, en el caso de 32 bits sería:
http://packages.ubuntu.com/maverick/i38 ... 2/download
... etc, sustituyendo el "amd64" por "i386". Lo único que tenéis que hacer es, como siempre, "sudo dpkg -i nombre_paquete.deb"

Yo ya lo tengo funcionando y es genial. Os aconsejo que os guardéis esos archivos descargados por si no se actualiza el programa en un tiempo.

¡Espero que sirva de ayuda!


Muchas gracias Jfcg ya pude instalarlo y hasta ahora parece que funciona bien. :lol: :mrgreen:
¿Una consulta respecto a las librerías, existe algun orden para instalarlas? ya que partí con el libavcodec y me daba error porque faltaban otras librerías, seguí con libavformat y me daba error porque el primero no estaba bien configurado (ahí ya me salía el aviso de paquetes rotos en el área de notificación) pasé a libx264-98 y la instaló, luego libswscale y finalmente libavutil. Hice un update y desapareció la notificación de paquetes rotos y luego instalé el juego como de costumbre y no tuve problemas.
Pero me queda esa duda... hay algún orden para instalar las librerías (y a mi me resultó de pura suerte) o da igual. :roll:

PD: al fallar el primer paquete, la consola me nombraba muchas librerías por lo que no estaba seguro de con cual seguir y por eso lo hice, digamos que, al azar :|
crow0300
Desafinado
 
Mensajes: 4
Registrado: Viernes 16 de Julio de 2010 a las 07:00

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor manolito2008 » Domingo 6 de Mayo de 2012 a las 00:24

Los enlaces a las librerías están caídos y no encuentro otros :(
Le estoy dando vueltas a esto hace un buen rato.

Tenía todo hermoso funcionando con Ubuntu 10.04 64 bits pero compré una placa de sonido USB (para usar Mixxx con una mezcladora externa) y no me la tomaba. Actualicé entonces a Ubuntu 12.04 64 bits y ahora me toma bien la placa de sonido usb, pero no puedo instalar ultrastar deluxe por ese mismo problema de dependencia con el libavcodec52 y libavcodec-extra-52.
manolito2008
Desafinado
 
Mensajes: 1
Registrado: Miércoles 18 de Abril de 2012 a las 23:31

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor daniel20 » Domingo 6 de Mayo de 2012 a las 09:09

anda bastante dejao el proyecto en linux, creo que en un futuro volveremos a tener soporte, pero ahora mismo anda bastante parado.
¿no sabes cómo configurar tus micros? ¿no sabes descargar? ¿problemas? Quizás tu duda ya ha sido resuelta en la sección de Ayuda (arriba en la web)
Avatar de Usuario
daniel20
Moderador
Moderador
 
Mensajes: 4040
Registrado: Viernes 27 de Febrero de 2009 a las 19:50

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor crow0300 » Miércoles 16 de Mayo de 2012 a las 02:10

En Ubuntu 12.04 se necesitan 4 librerías más que en Oneiric para poder funcionar. Éstas son :
libvpx0 https://launchpad.net/ubuntu/precise/amd64/libvpx0/0.9.7.p1-2
projectm-data https://launchpad.net/ubuntu/precise/amd64/projectm-data/2.0.1+dfsg-12
libftgl2 https://launchpad.net/ubuntu/precise/amd64/libftgl2/2.1.3~rc5-4
libprojectm2 https://launchpad.net/ubuntu/precise/amd64/libprojectm2/2.0.1+dfsg-12
(los links son las versiones de 64bits)

Pero efectivamente como dice manolito2008 los links de la version anterior ya no estan disponibles. Yo no los tuve que buscar porque los tenía respaldados en un HDD, de modo que para los que necesiten las librerías del juego -y siempre que no haya ningún inconveniente en compartirlos- se los dejo en una carpeta de Dropbox https://www.dropbox.com/sh/g5p4xnckprb3gr8/RvnBhnvnJn.
Son las 9 librerias para la arquitectura de 64bits. Están con un numero al principio del archivo que indica el orden en que hay que instalarlas. Yo lo instale vía Terminal y el juego me corre perfectamente, pero imagino que no habrá problemas al instalarlas por medio del Centro de Software. ;)
crow0300
Desafinado
 
Mensajes: 4
Registrado: Viernes 16 de Julio de 2010 a las 07:00

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor homosapiens999 » Miércoles 16 de Mayo de 2012 a las 05:18

crow0300 escribió:En Ubuntu 12.04 se necesitan 4 librerías más que en Oneiric para poder funcionar. Éstas son :
libvpx0 https://launchpad.net/ubuntu/precise/amd64/libvpx0/0.9.7.p1-2
projectm-data https://launchpad.net/ubuntu/precise/amd64/projectm-data/2.0.1+dfsg-12
libftgl2 https://launchpad.net/ubuntu/precise/amd64/libftgl2/2.1.3~rc5-4
libprojectm2 https://launchpad.net/ubuntu/precise/amd64/libprojectm2/2.0.1+dfsg-12
(los links son las versiones de 64bits)

Pero efectivamente como dice manolito2008 los links de la version anterior ya no estan disponibles. Yo no los tuve que buscar porque los tenía respaldados en un HDD, de modo que para los que necesiten las librerías del juego -y siempre que no haya ningún inconveniente en compartirlos- se los dejo en una carpeta de Dropbox https://www.dropbox.com/sh/g5p4xnckprb3gr8/RvnBhnvnJn.
Son las 9 librerias para la arquitectura de 64bits. Están con un numero al principio del archivo que indica el orden en que hay que instalarlas. Yo lo instale vía Terminal y el juego me corre perfectamente, pero imagino que no habrá problemas al instalarlas por medio del Centro de Software. ;)


Saludos Googleando llegue a este tema, he instalado todas las librerías que pones en tu carpeta de dropbox, y se resolvieorn muchas dependencias, ahora el problema es que me da otro error, me pide

ultrastar-deluxe-data

Sabes de donde puedo bajar esa o como puedo instalarla??
Imagen
homosapiens999
Antiguo Creador
Antiguo Creador
 
Mensajes: 24
Registrado: Domingo 6 de Junio de 2010 a las 03:02
Ubicación: México

Re: Ubuntu 11.10 oneric y Ultrastar deluxe

Notapor crow0300 » Miércoles 16 de Mayo de 2012 a las 05:33

homosapiens999 escribió:
crow0300 escribió:En Ubuntu 12.04 se necesitan 4 librerías más que en Oneiric para poder funcionar. Éstas son :
libvpx0 https://launchpad.net/ubuntu/precise/amd64/libvpx0/0.9.7.p1-2
projectm-data https://launchpad.net/ubuntu/precise/amd64/projectm-data/2.0.1+dfsg-12
libftgl2 https://launchpad.net/ubuntu/precise/amd64/libftgl2/2.1.3~rc5-4
libprojectm2 https://launchpad.net/ubuntu/precise/amd64/libprojectm2/2.0.1+dfsg-12
(los links son las versiones de 64bits)

Pero efectivamente como dice manolito2008 los links de la version anterior ya no estan disponibles. Yo no los tuve que buscar porque los tenía respaldados en un HDD, de modo que para los que necesiten las librerías del juego -y siempre que no haya ningún inconveniente en compartirlos- se los dejo en una carpeta de Dropbox https://www.dropbox.com/sh/g5p4xnckprb3gr8/RvnBhnvnJn.
Son las 9 librerias para la arquitectura de 64bits. Están con un numero al principio del archivo que indica el orden en que hay que instalarlas. Yo lo instale vía Terminal y el juego me corre perfectamente, pero imagino que no habrá problemas al instalarlas por medio del Centro de Software. ;)


Saludos Googleando llegue a este tema, he instalado todas las librerías que pones en tu carpeta de dropbox, y se resolvieorn muchas dependencias, ahora el problema es que me da otro error, me pide

ultrastar-deluxe-data

Sabes de donde puedo bajar esa o como puedo instalarla??


Que bueno que te haya servido. El archivo Data no lo añadí pues di por hecho que lo tendrían :roll:
En fin, el archivo está en la página del proyecto (https://launchpad.net/~tobydox/+archive/ultrastardx/)
Lo descargas directamente desde acá: https://launchpad.net/~tobydox/+archive/ultrastardx/+files/ultrastar-deluxe-data_1.1.0-4_all.deb

Si ya instalaste todas las librerías, ahora instalas el archivo Data y luego el instalador normal del juego (https://launchpad.net/~tobydox/+archive/ultrastardx/+files/ultrastar-deluxe_1.1.0-4_amd64.deb) y con esto ya podrás jugar sin ningún problema.

PD: para el tema de guardar las canciones te dejo con las instrucciones que Daniel20 hizo en el tutorial Instalando ultrastar ubuntu (11.04) donde lo deja bastante claro http://ultrastar-es.org/tutoriales.php?id=4208

Saludos ;)
crow0300
Desafinado
 
Mensajes: 4
Registrado: Viernes 16 de Julio de 2010 a las 07:00


Volver a UltraStar Deluxe y otros programas

¿Quién está conectado?

Usuarios navegando por este Foro: Guainos y 1 invitado