Nueva Raspberry Pi 4 y Ultrastar

Para hablar del juego y que no tenga cabida en otro foro
Reglas del Foro
Prohibido pedir canciones en el foro. Si quieres hacerlo que sea aquí
Avatar de Usuario
0dric
Supercreador
Supercreador
Mensajes: 174
Registrado: Viernes 27 de Noviembre de 2015 a las 22:18
Ubicación: Frontera del Bidasoa

Nueva Raspberry Pi 4 y Ultrastar

Mensaje por 0dric »

¿Alguien ha probado que tal va?
Parece que ya no tendría problema moviendo videos ¿No?
Avatar de Usuario
0dric
Supercreador
Supercreador
Mensajes: 174
Registrado: Viernes 27 de Noviembre de 2015 a las 22:18
Ubicación: Frontera del Bidasoa

Mensaje por 0dric »

Y ya si eso, ¿Se puede instalar en linux? ¿raspbian?
No encuentro nada al respecto en worldparty, algun archivo en github parece hacer referencia a linux pero no llego a tanto.
Por si pillo a alguno con la pi4 y le pido que pruebe por mi.
Gracias.
Avatar de Usuario
daniel20
Colaborador
Colaborador
Mensajes: 6586
Registrado: Viernes 27 de Febrero de 2009 a las 20:50

Mensaje por daniel20 »

la versión 4 estaría limitada a videos HD pero no para videos fullHD para eso habrá que esperar a la versión 5.(Aunque R.Pi4 puede reproducir videos en 4k, como el juego tiene que cargar muchas más capas se verían limitados los videos)

Puedes compilarlo a través de linux.

Las instrucciones de linux las tienes en el primer mensaje: https://ultrastar-es.org/foro/viewtopic.php?f=2&t=9935
¿no sabes cómo configurar tus micros? ¿no sabes descargar? ¿problemas? Quizás tu duda ya ha sido resuelta en la sección de Ayuda (arriba en la web)
Avatar de Usuario
0dric
Supercreador
Supercreador
Mensajes: 174
Registrado: Viernes 27 de Noviembre de 2015 a las 22:18
Ubicación: Frontera del Bidasoa

Mensaje por 0dric »

Joe gracias, mira que me sonaba haberlo visto pero no he sido capaz con el buscador.
Si consigo probarlo ya os contaré.
xarly_88
Desafinado
Mensajes: 1
Registrado: Martes 6 de Octubre de 2009 a las 17:01

Mensaje por xarly_88 »

Hola!!! Yo con esto de la cuarentena he intentado seguir un scrip que hay en github que sale de una pagina de fororaspberry.es y no consigo hacerlo funcionar. mi raspberry es la 4 con 4gb de ram. haber si hay alguien al que le funcione
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

xarly_88 escribió: Viernes 10 de Abril de 2020 a las 13:56 Hola!!! Yo con esto de la cuarentena he intentado seguir un scrip que hay en github que sale de una pagina de fororaspberry.es y no consigo hacerlo funcionar. mi raspberry es la 4 con 4gb de ram. haber si hay alguien al que le funcione
si es el que yo he visto esta desactualizado y no utiliza la ultima versión del worldparty
a ver si podemos lanzar un paquete snap dentro de poco para que sea más fácil de instalar sobre todo en equipos así
No respondo a mensajes privados sobre temas que podrían estar en el foro
jalabanda
Desafinado
Mensajes: 1
Registrado: Jueves 30 de Julio de 2020 a las 19:46

Mensaje por jalabanda »

Yo he conseguido instalar Ultrastar en una Raspberry pi4 siguiendo las indicaciones de este enlace:

[EDITADO]

A mi me esta funcionando.

Saludos.
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

jalabanda escribió: Viernes 31 de Julio de 2020 a las 10:25 Yo he conseguido instalar Ultrastar en una Raspberry pi4 siguiendo las indicaciones de este enlace:

[EDITADO]

A mi me esta funcionando.

Saludos.
aqui solo damos soporte para el woldparty ;)
No respondo a mensajes privados sobre temas que podrían estar en el foro
Avatar de Usuario
0dric
Supercreador
Supercreador
Mensajes: 174
Registrado: Viernes 27 de Noviembre de 2015 a las 22:18
Ubicación: Frontera del Bidasoa

Mensaje por 0dric »

Pregunto por aclararme,
¿No dais soporte oficial a otras versiones?
¿o nadie puede hablar de otras versiones?
Ni siquiera he visto el enlace, pensaba que era a la primera opción, por confirmar.
Avatar de Usuario
daniel20
Colaborador
Colaborador
Mensajes: 6586
Registrado: Viernes 27 de Febrero de 2009 a las 20:50

Mensaje por daniel20 »

Solo damos soporte a la versión worldparty. (actualmente funciona con windows, y linux, también se puede ejecutar en pi 4, para mac no hay soporte)
El resto de proyectos podéis buscarlos a través de duckduckgo, google...
Bloqueamos el resto de proyectos, primero porque no lo desarrollamos nosotros y no es compatible con el resto de trabajo que hacemos nosotros, y segundo para no dar crédito gratuito a costa de nuestra comunidad. (la historia es algo más larga, pero se resume en esto)
¿no sabes cómo configurar tus micros? ¿no sabes descargar? ¿problemas? Quizás tu duda ya ha sido resuelta en la sección de Ayuda (arriba en la web)
Avatar de Usuario
0dric
Supercreador
Supercreador
Mensajes: 174
Registrado: Viernes 27 de Noviembre de 2015 a las 22:18
Ubicación: Frontera del Bidasoa

Mensaje por 0dric »

Ok, queda claro.
tmaing
Creador
Creador
Mensajes: 15
Registrado: Miércoles 2 de Mayo de 2018 a las 12:18

Mensaje por tmaing »

Pues esperando como agua de mayo una rasp 5 para poder hacer portable esta maravilla.
Manu_75
Desafinado
Mensajes: 7
Registrado: Lunes 16 de Diciembre de 2019 a las 00:21

Mensaje por Manu_75 »

Hello all,
I have tried today to install Ultrastar World Party on Raspbian running on my new Raspberry Pi 4.
I have followed these instructions: https://snapcraft.io/install/usdxworldparty/raspbian
At last step, when I use command "sudo snap install usdxworldparty --edge" I've got the following error message:
error "usdxworldparty"is not available on edge for this architecture (armhf) but exists on other architectures (amd64, arm64, i386).
Is there a way to overcome this error mesage?
Thanks!
Avatar de Usuario
0dric
Supercreador
Supercreador
Mensajes: 174
Registrado: Viernes 27 de Noviembre de 2015 a las 22:18
Ubicación: Frontera del Bidasoa

Mensaje por 0dric »

Manu_75
Desafinado
Mensajes: 7
Registrado: Lunes 16 de Diciembre de 2019 a las 00:21

Mensaje por Manu_75 »

Thanks for your response. I have tried your procedure this morning on Ubuntu but I get the following error messages when using sudo ./install

/home/manu/ultrastar-worldparty/src/base/UMusic.pas(248,61) Error: Procedure directive "STATIC" cannot be used with "VIRTUAL"
/home/manu/ultrastar-worldparty/src/base/UMusic.pas(649,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
Error: /usr/bin/ppca64 returned an error exitcode
make[1]: *** [Makefile:256 : ../game/WorldParty] Erreur 1
make[1] : on quitte le répertoire « /home/manu/ultrastar-worldparty/src »
make: *** [Makefile:115 : all] Erreur 2
/usr/bin/mkdir -p "/usr/local/bin"
/usr/bin/install -c "./game/WorldParty" "/usr/local/bin"
/usr/bin/install: impossible d'évaluer './game/WorldParty': Aucun fichier ou dossier de ce type
make: *** [Makefile:225 : install-exec] Erreur 1

Did I missed some step?
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

no, the compilation in linux is broken at this momment
you must wait to the next release of worldparty to use it in your raspi
No respondo a mensajes privados sobre temas que podrían estar en el foro
Avatar de Usuario
0dric
Supercreador
Supercreador
Mensajes: 174
Registrado: Viernes 27 de Noviembre de 2015 a las 22:18
Ubicación: Frontera del Bidasoa

Mensaje por 0dric »

Igual es una pregunta absurda.
¿Y hay forma de instalar una versión anterior que si este completa?
Avatar de Usuario
daniel20
Colaborador
Colaborador
Mensajes: 6586
Registrado: Viernes 27 de Febrero de 2009 a las 20:50

Mensaje por daniel20 »

@0dric para ello tenemos que crear previamente un snap o un flatpak, que es similar a un exe en windows. En linux se distribuye el programa sin librerías adicionales, por lo que se instalan aparte. Si alguna de estas librerías se actualizan rompiendo las conexiones con el programa, éste deja de funcionar. Al crear un paquete con todas las librerias adicionales, evitas precisamente eso.
¿no sabes cómo configurar tus micros? ¿no sabes descargar? ¿problemas? Quizás tu duda ya ha sido resuelta en la sección de Ayuda (arriba en la web)
Avatar de Usuario
0dric
Supercreador
Supercreador
Mensajes: 174
Registrado: Viernes 27 de Noviembre de 2015 a las 22:18
Ubicación: Frontera del Bidasoa

Mensaje por 0dric »

Entendido, gracias por la explicación
joshiko
Desafinado
Mensajes: 8
Registrado: Viernes 4 de Marzo de 2011 a las 21:51

Mensaje por joshiko »

Buenas, para cuando saldrá la nueva versión que funcione? Gracias!
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

estoy intentando que alguien pruebe el snap y me diga si funciona, así que si quieres probar... https://snapcraft.io/ultrastar-worldparty
No respondo a mensajes privados sobre temas que podrían estar en el foro
joshiko
Desafinado
Mensajes: 8
Registrado: Viernes 4 de Marzo de 2011 a las 21:51

Mensaje por joshiko »

TeLiXj escribió: Jueves 4 de Febrero de 2021 a las 17:16 estoy intentando que alguien pruebe el snap y me diga si funciona, así que si quieres probar... https://snapcraft.io/ultrastar-worldparty

Lo he probado en Ubuntu para rpi4, se instala perfecto pero no encuentro el ejecutable y al lanzarlo vía terminal da un error de excepción.
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

se te ha tenido que añadir un acceso directo en el menú, en la sección juegos
o si usas el buscador de aplicaciones y pones worldparty te debería salir
y si no te sale dime que escritorio estas utilizando, entiendo que si es Ubuntu estándar será GNOME
es que todavía no me ha dado tiempo a probar en otra cosa que no sea KDE Plasma en mis ordenadores, de hecho acabo de probar en uno y el acceso directo no funciona como esperaba porque no se establece la codificación por defecto

lo que no falla es ejecutarlo desde consola poniendo

Código: Seleccionar todo

env LC_ALL=C.UTF-8 snap run ultrastar-worldparty
y el directorio del juego esta en ~/snap/ultrastar-worldparty/current/.ultrastar-worldparty
No respondo a mensajes privados sobre temas que podrían estar en el foro
joshiko
Desafinado
Mensajes: 8
Registrado: Viernes 4 de Marzo de 2011 a las 21:51

Mensaje por joshiko »

Ahora sí! Gracias! Voy a ver si puedo meterle alguna canción para probar, y a ver si me reconoce los micrófonos de SingStar de PS2
joshiko
Desafinado
Mensajes: 8
Registrado: Viernes 4 de Marzo de 2011 a las 21:51

Mensaje por joshiko »

TeLiXj escribió: Jueves 4 de Febrero de 2021 a las 21:50 se te ha tenido que añadir un acceso directo en el menú, en la sección juegos
o si usas el buscador de aplicaciones y pones worldparty te debería salir
y si no te sale dime que escritorio estas utilizando, entiendo que si es Ubuntu estándar será GNOME
es que todavía no me ha dado tiempo a probar en otra cosa que no sea KDE Plasma en mis ordenadores, de hecho acabo de probar en uno y el acceso directo no funciona como esperaba porque no se establece la codificación por defecto

lo que no falla es ejecutarlo desde consola poniendo

Código: Seleccionar todo

env LC_ALL=C.UTF-8 snap run ultrastar-worldparty
y el directorio del juego esta en ~/snap/ultrastar-worldparty/current/.ultrastar-worldparty
Pues nada, consigo que arranque (aunque no he conseguido meter ninguna canción ya que no encuentro el directorio songs para volcarlas). Lo peor es que no me reconoce los micros, si me aparecen correctamente como micro en ubuntu pero al entrar en la configuración de los micros en el UltraStar se queda pillado y tengo que matarlo para poder salir.

https://photos.app.goo.gl/nK71JedR7YX7gTxW7

aquí dejo un video con lo que me sucede y esta imagen de cuando lo ejecuto con la opción -debug:

Imagenhttps://photos.app.goo.gl/qVUnif3KKqqBJ9138
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

las canciones las puedes meter en el directorio que te dije, crea una carpeta que se llame songs o edita el config.ini y en SongDir1 pon el directorio donde las tengas

respecto a lo del sonido en la version amd64 suele fallar al iniciar (sobre todo la primera vez tras instalarlo) pero luego acaba entrando, y ahí ya no falla
a ti sin embargo te pone que el pulseaudio no ha podido arrancar ¿te sucede siempre? ¿no tienes otro micro para probar? a lo mejor el de la tele que te lo detecte o algún otro
No respondo a mensajes privados sobre temas que podrían estar en el foro
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

He estado mirando y ya se lo que puede estar pasando, que por defecto no asigna todos los permisos para usar las cosas del ordenador
prueba a poner esto a ver si va

Código: Seleccionar todo

sudo snap connect ultrastar-worldparty:raw-usb :raw-usb
sudo snap connect ultrastar-worldparty:audio-record :audio-record
No respondo a mensajes privados sobre temas que podrían estar en el foro
joshiko
Desafinado
Mensajes: 8
Registrado: Viernes 4 de Marzo de 2011 a las 21:51

Mensaje por joshiko »

Al final me he puesto y hace un rato que lo tengo funcionando tras bajarlo y compilarlo de GitHub👏👏👏👏
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

aaah vale, pues me alegro aunque haya sido manualmente :D
pero si probaras esto me harías un gran favor con el snap que he subido hoy. Que al ser esto tan nuevo todavía hay cosillas por pulir y entre todos me vais ayudando a mejorarlo
No respondo a mensajes privados sobre temas que podrían estar en el foro
joshiko
Desafinado
Mensajes: 8
Registrado: Viernes 4 de Marzo de 2011 a las 21:51

Mensaje por joshiko »

TeLiXj escribió: Lunes 8 de Febrero de 2021 a las 00:59 aaah vale, pues me alegro aunque haya sido manualmente :D
pero si probaras esto me harías un gran favor con el snap que he subido hoy. Que al ser esto tan nuevo todavía hay cosillas por pulir y entre todos me vais ayudando a mejorarlo
Lo pruebo estos días y te digo
joshiko
Desafinado
Mensajes: 8
Registrado: Viernes 4 de Marzo de 2011 a las 21:51

Mensaje por joshiko »

TeLiXj escribió: Lunes 8 de Febrero de 2021 a las 00:59 aaah vale, pues me alegro aunque haya sido manualmente :D
pero si probaras esto me harías un gran favor con el snap que he subido hoy. Que al ser esto tan nuevo todavía hay cosillas por pulir y entre todos me vais ayudando a mejorarlo
Buenas, acabo de probar y sigue igual, no coge los micros y se queda pillado si entro a configurarlos.

Código: Seleccionar todo

$ snap run ultrastar-worldparty
Testing for explicit PulseAudio choice...
Testing for ALSA permissions...
...defaulting to using PulseAudio.
An unhandled exception occurred at $0000000000000000:
EAccessViolation: Access violation
  $0000000000000000

An unhandled exception occurred at $0000000000000000:
EAccessViolation: Access violation
  $0000000000000000

An unhandled exception occurred at $0000000000000000:
EAccessViolation: Access violation
  $0000000000000000

An unhandled exception occurred at $0000000000000000:
EAccessViolation:
  $0000000000000000
Además, la versión que instalé de github no se por que me habia comenzado a fallar sin hacer nada, al elegir una canción para cantar daba error y se salia:

Este es el Error.log:

Código: Seleccionar todo

cat .ultrastar-worldparty/logs/Error.log
UltraStar WorldParty 20.12 Error Log
Date: 11-2-21 Time: 20:19:27
-------------------
[11-2-21 20:19:27] STATUS: Search complete: 1 songs found (0 with errors) [SongList]
[11-2-21 20:19:30] STATUS: Use config resolution [SDL_SetVideoMode]
[11-2-21 20:19:30] STATUS: Creating window [SDL_SetVideoMode]
[11-2-21 20:19:30] STATUS: Set Video Mode...   Borderless fullscreen [SDL_SetVideoMode]
[11-2-21 20:19:30] INFO:   OpenGL vendor Broadcom [UGraphic.InitializeScreen]
[11-2-21 20:19:30] INFO:   OpenGL renderer V3D 4.2 [UGraphic.InitializeScreen]
[11-2-21 20:19:30] INFO:   OpenGL version 2.1 Mesa 20.2.6 [UGraphic.InitializeScreen]
[11-2-21 20:19:31] INFO:   OpenGL vendor Broadcom [TTextureUnit.Create]
[11-2-21 20:19:31] INFO:   OpenGL renderer V3D 4.2 [TTextureUnit.Create]
[11-2-21 20:19:31] INFO:   OpenGL version 2.1 Mesa 20.2.6 [TTextureUnit.Create]
[11-2-21 20:19:31] INFO:   OpenGL TextureNPOT-support: -1 [TTextureUnit.Create]
[11-2-21 20:19:32] STATUS: Opened audio device [TAudioPlayback_SDL.InitializeAudioPlaybackEngine]
[11-2-21 20:19:32] INFO:   Using pulseaudio driver [SDL]
[11-2-21 20:19:32] STATUS: InputDevice "[Default]"@2x44100Hz defaults to 2048 samples buffer [SDL]
[11-2-21 20:19:32] STATUS: #Input-Devices: 1 [SDL]
[11-2-21 20:19:32] INFO:   Using decoder FFmpeg_Decoder for "/usr/local/share/WorldParty/sounds/forward sound.mp3" [TAudioPlaybackBase.OpenDecodeStream]
[11-2-21 20:19:32] INFO:   Using decoder FFmpeg_Decoder for "/usr/local/share/WorldParty/sounds/back sound.mp3" [TAudioPlaybackBase.OpenDecodeStream]
[11-2-21 20:19:32] INFO:   Using decoder FFmpeg_Decoder for "/usr/local/share/WorldParty/sounds/option sound.mp3" [TAudioPlaybackBase.OpenDecodeStream]
[11-2-21 20:19:32] INFO:   Using decoder FFmpeg_Decoder for "/usr/local/share/WorldParty/sounds/background track.mp3" [TAudioPlaybackBase.OpenDecodeStream]
[11-2-21 20:19:32] INFO:   Using decoder FFmpeg_Decoder for "/usr/local/share/WorldParty/sounds/beat click.mp3" [TAudioPlaybackBase.OpenDecodeStream]
[11-2-21 20:19:32] STATUS: Initialize Joystick [Initialization]
[11-2-21 20:19:32] STATUS: Joystick count: 0 [TJoy.Create]
[11-2-21 20:19:32] STATUS: No GameController/Joystick connected. [TJoy.Create]
[11-2-21 20:19:32] STATUS:   # Name                           Version  Status     Paused  #Errors [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   0 party mode: holdtheline        0.6      running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   1 party mode: blindTotal         1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   2 party mode: 1000blind          1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   3 party mode: 500blind           1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   4 party mode: blindLyrics        1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   5 party mode: blind              1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   6 party mode: shortsong          1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   7 party mode: 5000points         1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   8 party mode: deaf               1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:   9 party mode: hardcore           1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:  10 party mode: 5000pointsblind    1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:  11 party mode: 2000pointsblind    1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:  12 party mode: 2000points         1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:  13 party mode: teamduel           1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:  14 party mode: holdthelineblind   0.6      running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:  15 party mode: 5000pointsblind    1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:  16 party mode: duel               1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:32] STATUS:  17 party mode: 7000points         1.00     running    False   0      [LuaCore Plugins]
[11-2-21 20:19:42] INFO:   Using decoder FFmpeg_Decoder for "/home/joshiko/.ultrastar-worldparty/songs/Rosendo - Agradecido/Rosendo - Agradecido.mp3" [TAudioPlaybackBase.OpenDecodeStream]
[11-2-21 20:19:42] INFO:   VideoStreamIndex : -1 [TVideoPlayback_ffmpeg.Open]
[11-2-21 20:19:42] INFO:   Framerate: 29fps [TVideoPlayback_ffmpeg.Open]
[11-2-21 20:19:45] STATUS: Begin [OnShow]
[11-2-21 20:19:45] INFO:   VideoStreamIndex : -1 [TVideoPlayback_ffmpeg.Open]
[11-2-21 20:19:45] INFO:   Framerate: 29fps [TVideoPlayback_ffmpeg.Open]
[11-2-21 20:19:45] STATUS: Begin [OnShow]
[11-2-21 20:19:45] INFO:   VideoStreamIndex : -1 [TVideoPlayback_ffmpeg.Open]
[11-2-21 20:19:45] INFO:   Framerate: 29fps [TVideoPlayback_ffmpeg.Open]
[11-2-21 20:19:45] STATUS: Closing DB file [Finalization]
[11-2-21 20:19:45] INFO:   TDataBaseSystem.Free [TDataBaseSystem.Destroy]
[11-2-21 20:19:45] STATUS: Finalize Media [Finalization]
[11-2-21 20:19:45] STATUS: Uninitialize Joystick [Finalization]
[11-2-21 20:19:45] STATUS: Uninitialize 3D [Finalization]
[11-2-21 20:19:45] STATUS: Kill Fonts [UnloadFontTextures]
[11-2-21 20:19:45] STATUS: Finalize SDL [Finalization]
[11-2-21 20:19:45] STATUS: Finalize Log [Finalization]
Y esto lo que vuelca por pantalla:

Código: Seleccionar todo

 WorldParty -debug
Sorry, an error ocurred! Please report this error to https://ultrastar-es.org/foro Also check the Error.log file in the game folder.
Stacktrace:
Exception class: EAccessViolation
Message: Access violation
  $000000000050FB28
  $000000000047A41C
  $000000000048F828
  $000000000048F5F0
  $0000000000406B28
  $0000FFFFB9212878
  $0000000000406A88
An unhandled exception occurred at $00000000004257FC:
EAccessViolation: Access violation
  $00000000004257FC
  $0000000000425A14
  $0000000000424698
  $0000000000419DAC
  $0000000000421FA4
  $00000000004BF120
  $0000000000423114
  $000000000042353C
  $000000000042358C
  $0000000000406D98
  $0000FFFFB9212878
  $0000000000406A88

An unhandled exception occurred at $00000000004257FC:
EAccessViolation: Access violation
  $00000000004257FC
  $0000000000425A14
  $0000000000424698
  $0000000000419DAC
  $0000000000421FA4
  $00000000004DD248
  $0000000000423114
  $000000000042353C
  $000000000042358C
  $00000000004235E4
  $000000000041F08C
  $000000000041F1F4
  $000000000058CCB0
  $0000000000423754
  $000000000043228C
  $0000FFFFBB2CF5D8
  $00000000004257F4

An unhandled exception occurred at $00000000004257B0:
EAccessViolation: Access violation
  $00000000004257B0
  $0000000000425A28
  $0000000000424698
  $0000000000412704
  $0000000000421ECC
  $0000000000421BA0
  $000000000041D814
  $000000000041CFA8
  $00000000004E7760
  $000000000041E944
  $000000000041C380
  $00000000004DA6FC
  $0000000000423114
  $000000000042353C
  $000000000042358C
  $00000000004235E4
  $000000000041F08C

An unhandled exception occurred at $00000000004257FC:
EAccessViolation:
  $00000000004257FC
  $0000000000425A14
  $0000000000424698
  $000000000041CFB0
  $000000000041CCD4
  $000000000041CD08
  $000000000058A794
  $00000000005862C0
  $00000000005863C4
  $0000000000591218
  $0000000000423114
  $000000000042353C
  $000000000042358C
  $00000000004235E4
  $000000000041F08C
  $000000000041F1F4
  $000000000058CCB0
He limpiado todo lo que había de ultrastar en /usr/local y /usr/bin, he descargado de nuevo desde github y vuelto a instalar y vuelve a funcionar. Lo curioso es que aunque funcione bien, al cerrar vuelve a soltar los mensajes de EAccessViolation.
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

joer pos una pena que falle aun añadiéndole los permisos. La verdad que con la versión de ubuntu en la que se basa el snap siempre fue problemática con el tema de lo micros

el error que da en pantalla no me sirve, el que lo devuelve inteligible es el ultrastar-worldparty-debug pero si has utilizado el install no lo compila y habría que hacerlo manualmente
y es raro porque esas canciones antiguas suelen utilizar códecs de la época que están muy probados, a saber que fue...

respecto a los exception al salir siempre los va a dar, porque hay cosas que no se cierran bien y no he conseguido detectar cuales son

de todas formas muchas gracias por la información!!!!
No respondo a mensajes privados sobre temas que podrían estar en el foro
joshiko
Desafinado
Mensajes: 8
Registrado: Viernes 4 de Marzo de 2011 a las 21:51

Mensaje por joshiko »

TeLiXj escribió: Jueves 11 de Febrero de 2021 a las 22:40 joer pos una pena que falle aun añadiéndole los permisos. La verdad que con la versión de ubuntu en la que se basa el snap siempre fue problemática con el tema de lo micros

el error que da en pantalla no me sirve, el que lo devuelve inteligible es el ultrastar-worldparty-debug pero si has utilizado el install no lo compila y habría que hacerlo manualmente
y es raro porque esas canciones antiguas suelen utilizar códecs de la época que están muy probados, a saber que fue...

respecto a los exception al salir siempre los va a dar, porque hay cosas que no se cierran bien y no he conseguido detectar cuales son

de todas formas muchas gracias por la información!!!!
De nada! Como se hace el debug y pruebo? Puedo crear un snap con mi instalación para probar?
Avatar de Usuario
TeLiXj
Administrador
Administrador
Mensajes: 7837
Registrado: Sábado 22 de Noviembre de 2008 a las 15:25

Mensaje por TeLiXj »

casi mejor compilalo que ya tienes todo lo necesario, que el snap ocupa 15 gigas y es un coñazo instalar todo y generarlo
ejecuta desde el directorio donde está el código:

Código: Seleccionar todo

dists/atom/linux/compile.sh . compile-debug-execute
con eso te genera el ejecutable dentro de la carpeta game y lo lanza
si quieres solo compilar pon compile-debug
No respondo a mensajes privados sobre temas que podrían estar en el foro